[rt-users] Problems installing rt-tracker dependancies (and thanks Phil)

Crazy Diamond iypoon at mail.com
Thu Aug 1 14:52:13 EDT 2002


First,

  Thanks to Phil for the response.  Yeah i did have a typo.  Unfortunately, it looks like i was installing it on the wrong debian system (an older one), and now i'm installing it on the new stable version of debian (woody).

  Anyway, i have to go back one step now and i can't seem to get two perl modules installed properly: DBD::Pg and Apache::Cookie

  I tried installing them using the perl CPAN tool and it didn't work.  I also tried downloading them and i get the following errors:

For Apache::Cookie: (the package is called libapreq-0.31 which contains the Apache::Cookie module):

lucky:/tmp/libapreq-0.31# perl Makefile.PL && make install
Writing Makefile for libapreq
Warning: -L../blib/arch/auto/libapreq changed to -L/tmp/libapreq-0.31/Request/../blib/arch/auto/libapreq
Writing Makefile for Apache::Request
Warning: -L../blib/arch/auto/libapreq changed to -L/tmp/libapreq-0.31/Cookie/../blib/arch/auto/libapreq
Writing Makefile for Apache::Cookie
Writing Makefile for libapreq
make[1]: Entering directory `/tmp/libapreq-0.31/c'
cc -c -I/usr/lib/perl5/auto/Apache/include -I/usr/lib/perl5/auto/Apache/include/modules/perl -DDEBIAN -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2   -DVERSION=\"0.10\" -DXS_VERSION=\"0.10\" -fPIC -I/usr/lib/perl/5.6.1/CORE  apache_request.c
In file included from apache_request.c:58:
apache_request.h:5: httpd.h: No such file or directory
apache_request.h:6: http_config.h: No such file or directory
apache_request.h:7: http_core.h: No such file or directory
apache_request.h:8: http_log.h: No such file or directory
apache_request.h:9: http_main.h: No such file or directory
apache_request.h:10: http_protocol.h: No such file or directory
apache_request.h:11: util_script.h: No such file or directory
make[1]: *** [apache_request.o] Error 1
make[1]: Leaving directory `/tmp/libapreq-0.31/c'
make: *** [subdirs] Error 2

It appears i have some http files missing? 

This is the error messages i get with the DBD::Pg module (using Perl's MCPAN utility):

Configuring Pg
Remember to actually read the README file !
please set environment variables POSTGRES_INCLUDE and POSTGRES_LIB !
Running make test
  Make had some problems, maybe interrupted? Won't test
Running make install
  Make had some problems, maybe interrupted? Won't install

I think the problem is the POSTGRES_INCLUDE and POSTGRES_LIB thing.  I don't know how to set environment variables though.

Any help would be appreciated, thanks in advance.
-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Get 4 DVDs for $.49 cents! plus shipping & processing. Click to join. 
http://adfarm.mediaplex.com/ad/ck/990-1736-3566-59





More information about the RT-Users mailing list