[rt-users] latest RT-3.6 and SSL

Andrew Kornilov andy at eva.dp.ua
Mon Oct 9 09:53:25 EDT 2006


Hello.

After upgrade to latest RT-3.6(rc2) from SVN i got strange error: when i 
try to Take new ticket, Open it or do something else, i get error:
================================
error:       could not find component for initial path 
'/mod_ssl:error:HTTP-request' (component roots are: 
'/var/www/html/rt/local/html', '/var/www/html/rt')
context:     
...     
200:      $self->{out_method} = sub { $$bufref .= $_[0] };
201:      }
202:      $self->{use_internal_component_caches} =
203:      $self->{interp}->use_internal_component_caches;
204:      $self->_initialize;
205:     
206:      return $self;
207:      }
208:     
...     
code stack:      /usr/lib/perl5/vendor_perl/HTML/Mason/Request.pm:204
/usr/lib/perl5/vendor_perl/Class/Container.pm:275
/usr/lib/perl5/vendor_perl/Class/Container.pm:353
/usr/lib/perl5/vendor_perl/HTML/Mason/Interp.pm:329
/usr/lib/perl5/vendor_perl/HTML/Mason/Interp.pm:323
/usr/lib/perl5/vendor_perl/HTML/Mason/CGIHandler.pm:123
/usr/lib/perl5/vendor_perl/HTML/Mason/CGIHandler.pm:73
/usr/lib/rt/bin/mason_handler.fcgi:76
================================
and URL in browser becomes 
"http://rt.domain.com:443/Ticket/Display.html?id=3524", not 
"https://rt.domain.com/Ticket/Display.html?id=3524". We're using SSL 
only and redirect all plain HTTP requests to to HTTPS. Before latest 
update all works fine (btw, selected action is commited, so ticket 
becomes my, open, closed and so on, only this error is annoying :)



More information about the RT-Users mailing list