[rt-users] RT 3.6.1 https issue

Jan Korbel jackc at teptin.net
Mon Oct 23 04:46:24 EDT 2006


Hello.

I'm testing latest stable version of RT (3.6.1) about a week and i have 
a problems with HTTPS only site. When i want to update ticket, data is 
sent but browser wanna go to URL:

https://mysite.tld:80/Ticket/Display.html?id=1

See HTTPS and port 80...

My site cfg:

Set($WebPort , 443);
Set($WebBaseURL , "https://mysite.tld");

I also tried:

Set($WebBaseURL , "https://mysite.tld:$WebPort");

$WebURL is default (only in RT_Config.pm).

Another strange thing is name of cookie:

RT_SID_SITE.80

 From share/html/Elements/SetupSessionCookie:

my $cookiename = "RT_SID_".$RT::rtname.".".$ENV{'SERVER_PORT'};

I tried to delete cookies and cache from browser and db (mysql) too and 
restarted Apache. Still same.

Only one HTTPS configuration, which is going fine so far, is RT/HTTP and 
mod_proxy in Apache with HTTPS ;) I know it's not so nice, so if you 
have some idea, write it.

H.

System info:

Debian 3.1 (stable Sarge)
Apache 2.0.54-5sarge1
libapache2-mod-perl2 2.0.2-0bpo1




More information about the RT-Users mailing list