[rt-users] Problem configuring LDAP with AD

Andrew Hodgson andrew at plaintalkit.com
Tue Oct 24 14:58:50 EDT 2006


eric.valor at daimlerchrysler.com wrote:
> 
> AFAIK, "inetOrgPerson" doesn't exist in Active Directory.

I've changed it to "user", which is one of the choices I can see in 
ADSIEdit (the others are organizationalPerson, top, person.)

> Use the LDAPAttrMap I posted to the Wiki at 
> http://wiki.bestpractical.com/index.cgi?LdapAttrMap

I have done, thank you for the page. I used this page when I set up the 
LDAP overlay originally.


> In your RT_SiteConfig.pm make sure you have the correct MatchList and base:

Check. My base is an OU (ou=ActiveUsers,dc=domain,dc=local).

> # A list of RT attrs which can uniquely identify a user,
> # # ordered from most to least preferred.
> Set($LdapRTAttrMatchList, ['Name', 'ExternalContactInfoId',
>                            'EmailAddress', 'RealName',
>                            'WorkPhone', 'Address1']

The final entry was set to Address2, so I've changed it to "1".

<snip...all in check>

I've doubled checked the configuration and I still get the 
LDAP_OPERATIONS_ERROR 1. I've tried it with different credentials, and 
different settings for objectClass, but as far as I can see there's no 
effect.

Any further help appreciated,

Andrew



More information about the RT-Users mailing list