[rt-users] login problem

Jeroen van Aart kroshka at atypon.com
Fri Feb 6 16:20:26 EST 2009


Hello,

I installed rt 3.8.2 from source on Debian Lenny, using mysql (Ver 14.12 
Distrib 5.0.51a, for debian-linux-gnu (x86_64) using readline 5.2) and 
an import from an rt 3.4.1 database of an rt install on Debian Etch. I 
followed the proper guidelines and successfully installed it and it is 
working fine. Except that it's asking for a login and password repeatedly.

For example, you log in as usual which works, then you click on a quick 
search item, no problems, then you click on a ticket in and it will 
prompt you for your credentials again before opening the ticket. If you 
repeat this the same thing will happen.

Perhaps this is an issue with the apache2 configuration? I have pasted 
my config below, I am using fast-cgi. Thanks in advance for any help.

<VirtualHost rt3.example.com:80>
         ServerSignature Off
         ServerName rt3.example.com
         ServerAdmin admin at example.com
         Redirect permanent / https://rt3.example.com
</VirtualHost>

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120 
-processes 10
<VirtualHost rt3.example.com:443>
         ServerSignature Off
         SSLEngine on
         SSLCertificateFile /etc/apache2/ssl/rt3.crt
         SSLCertificateKeyFile /etc/apache2/ssl/rt3.key

         ServerName rt3.example.com
         ServerAdmin unix at example.com

         DocumentRoot /opt/rt3/share/html
         # Pass through requests to display images
         Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

         ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/
</VirtualHost>



More information about the RT-Users mailing list